Page 1 of 1

Alert variables in Control Center

Posted: Wed Jan 15, 2020 7:25 pm
by jcheevers
Hello,

I'm relatively new to Nice Labels. I created a new Automation alert in Control Center, and I accepted the defaults. The alert email gets sent out, but variables such as [LabelFileName] are coming out as blank. I'm wondering if I missed a step. Any ideas are appreciated.

Thanks,
Joe

Re: Alert variables in Control Center

Posted: Wed Jan 15, 2020 11:53 pm
by Mytch
jcheevers,

Sometimes Automation can have errors that are not related to the label/printing process. For example, if you have an error during data processing or using some Trigger logic prior to setting the label name. If label is unknown at time of error, this field will be blank. Please let us know if this is not the case.

Thanks,
Mytch

Re: Alert variables in Control Center

Posted: Thu Jan 16, 2020 4:55 pm
by jcheevers
Hi,

Thanks for the reply. I created an automation alert. In the automation builder I am setting the [LabelFileName] prior to Open Label.
I removed the label files from the directory to trigger the alert. It's not putting the label name into the email though.

Thanks,
Joe

Re: Alert variables in Control Center

Posted: Fri Jan 17, 2020 7:24 pm
by Mytch
jcheevers,

Yes, exactly what I was describing where logic of setting the label itself is failing - not the label print itself. Printing error of a label will provide the name of the label having an issue. But if you have an error about setting the label name itself, then technically this is not a label printing issue. [LabelFileName] variable gets the current label, but in the case of the label not existing, no value will return.

I understand your concern about this functionality, but this seems to currently be working as designed. I recommend posting your concerns as a new idea:
viewforum.php?f=12

So that [LabelFileName] is returned for every Open Label action, even if the label does not exist. There might be a good reason this works how it does currently, though.

Regards,
Mytch