Pocket Nice Engine 5 problem

Pocket NiceLabel running on Windows Mobile devices

Moderators: Georges, milos, NiceLabel Support Team

Post Reply
sergejusz
Enthusiast
Posts: 9
Joined: Tue Feb 13, 2007 3:19 pm
Location: Dublin
Contact:

Pocket Nice Engine 5 problem

Post by sergejusz » Mon Apr 02, 2007 10:14 am

Hi,
I have problem using Pocket Nice Engine v.5. Printer is Intermec EasyCoder PF4i and device is Symbol Mc9090 handheld scanner. I always get error 1002 (no connection made target machine actively refused it ).
I tried NiceLabel samples and my own application. Printer is ok, it is reachable (ping) and desktop applications that use Nice Label v.5 are working well. Previous version of Pocket Nice Engine that used PocketPrintWrapper.dll worker fine.
So question is: What is wrong? Maybe somebody tried v5 and faced the same problems?

Kind regards
Serge
Kind regards
Sergejus

primoz
NiceLabel Development
NiceLabel Development
Posts: 22
Joined: Wed Nov 29, 2006 2:10 pm

Post by primoz » Mon Apr 02, 2007 10:42 am

Hi,

This problem occurs when Pocket NiceLabel cannot send data via TCP/IP,..

Can you access your printer from the device.

If you can then maybe something is wrong in your code can you send me part of your code where TCP/IP address is set.

sergejusz
Enthusiast
Posts: 9
Joined: Tue Feb 13, 2007 3:19 pm
Location: Dublin
Contact:

Post by sergejusz » Mon Apr 02, 2007 11:15 am

Hi,
Thank you for response.
Printer is reacheable from scanner (Ping succeeds). What's about code. I used Simple Sample project from NiceLabel v5 Integration Pack - just changed printer IP address.

pneOutput = PocketNiceEngine.EngineClassFactory.CreateOutput
pneOutput.Kind = PocketNiceEngine.OutputKindType.TcpIP
pneOutput.SetTcpIp("192.168.200.44", 9100)
'Set label's output
pneLabel.Output = pneOutput

Also I tried EuroPlus PocketNiceLabel.exe with configurable printer settings. The same result as well.

Kind regards
Serge
Kind regards
Sergejus

primoz
NiceLabel Development
NiceLabel Development
Posts: 22
Joined: Wed Nov 29, 2006 2:10 pm

Post by primoz » Mon Apr 02, 2007 12:57 pm

Hi,

The code looks ok to me.

Is result the same if you print from device which is in the cradle and out of the cradle.

Regards,
primoz

sergejusz
Enthusiast
Posts: 9
Joined: Tue Feb 13, 2007 3:19 pm
Location: Dublin
Contact:

Post by sergejusz » Mon Apr 02, 2007 1:17 pm

Hi again,
the result is the same - bad - no connection.

Serge
Kind regards
Sergejus

primoz
NiceLabel Development
NiceLabel Development
Posts: 22
Joined: Wed Nov 29, 2006 2:10 pm

Post by primoz » Mon Apr 02, 2007 1:41 pm

Hi,

This is strange. Look like some kind network problem to me or maybe wrong port number (??).

What about if you uninstall v5 and install V4 again does it work with the same settings (IP ,port).

Regards,
primoz

sergejusz
Enthusiast
Posts: 9
Joined: Tue Feb 13, 2007 3:19 pm
Location: Dublin
Contact:

Post by sergejusz » Mon Apr 02, 2007 2:08 pm

Hi,
It's very good advice :)
I hoped somebody who is using v5 also faced similar problems.
Of course, I'll do that. I hope everything will be ok with v.4.
Thank you.

Serge
Kind regards
Sergejus

sergejusz
Enthusiast
Posts: 9
Joined: Tue Feb 13, 2007 3:19 pm
Location: Dublin
Contact:

Post by sergejusz » Mon Apr 02, 2007 3:11 pm

Hi again primoz,
I am back with results I've expected. I downloaded Pocket Nice Label for 4.1 (Build 949). I used pnice.exe application to print test label. It works fine. So, I suspect, something is not good with v5.
Kind regards
Sergejus

primoz
NiceLabel Development
NiceLabel Development
Posts: 22
Joined: Wed Nov 29, 2006 2:10 pm

Post by primoz » Tue Apr 03, 2007 9:22 am

Hi ,

Can you send me your sample label I will try to debug the Pocket NiceLabel application to see if anything is wrong with it.

Regards,
primoz
Last edited by primoz on Wed Apr 04, 2007 10:51 am, edited 1 time in total.

sergejusz
Enthusiast
Posts: 9
Joined: Tue Feb 13, 2007 3:19 pm
Location: Dublin
Contact:

important detail missed

Post by sergejusz » Wed Apr 04, 2007 10:01 am

Hi,
Sorry, I've forgotten important detail.
Handheld device is working under Microsoft Windows Mobile v.5.0 OS 5.1.70 (Build 14402.1.10)
Kind regards
Sergejus

Post Reply