SQL server 2012 increase remote query timeout in NL

Software technical issues not related to any of the other categories

Moderators: Georges, milos, NiceLabel Support Team

Post Reply
vijaya raghava
Enthusiast
Posts: 8
Joined: Wed Mar 15, 2017 7:51 am

SQL server 2012 increase remote query timeout in NL

Post by vijaya raghava » Wed Mar 15, 2017 4:46 pm

Version 6

when we are running a query against the event table we are getting the following errors:

2017-02-17 13:14:37
2017-02-17 18:33:21 There was another timeout logged.
An error occurred while trying to execute "Execute SQL Statement" action. An error occurred in the execution of the SQL statement. Cannot connect to database.
Server: sqlv\NICELBL
Database: NM_Product_Data System error message: Connection Timeout Expired

for this the DBA has increased the remote query timeout(path: rightclick->properties->connections) in SQL server to 6000 and asked to do the same in NL application as well.

Which parameter should I change in NL that reflects the remote query timeout in SQL server 2012

I am new to NL. Please let me know if I need to provide more details to give suggestions.

User avatar
Saso
NiceLabel
NiceLabel
Posts: 2933
Joined: Mon Sep 04, 2006 8:09 am
Contact:

Re: SQL server 2012 increase remote query timeout in NL

Post by Saso » Thu Mar 16, 2017 1:24 pm

For action "Execute SQL Statement" there is a default timeout of 30 seconds, which the user cannot modify.

However, you can enable the retry options in this action so that can be used as a solution.
You can configure retry attempts and time interval between attempts.
Saso Fleiser
Senior Technical Product Specialist

vijaya raghava
Enthusiast
Posts: 8
Joined: Wed Mar 15, 2017 7:51 am

Re: SQL server 2012 increase remote query timeout in NL

Post by vijaya raghava » Mon Mar 20, 2017 10:17 pm

Thanks Saso

Post Reply