iecore.dll error

Software technical issues not related to any of the other categories

Moderators: Georges, milos, NiceLabel Support Team

Post Reply
IanG
Enthusiast
Posts: 7
Joined: Thu Mar 09, 2017 10:04 am

iecore.dll error

Post by IanG » Wed Apr 24, 2019 2:00 pm

Hello,

[EDIT] It seems the images did not load. I have linked them instead
[EDIT2] I have re-installed the software multiple times, and used the latest version I have (17.3.1 Build 2491)

I am having trouble with NiceLabel 2017 on one of our machines.

I have a solution made, and when I attempt to view the solution in NiceLabel Print. The solution shows up (in the little thumbnail) with a circle with a cross through it. The user has read and write access to the folder (in screenshot below, I tested on admins desktop)
https://imgur.com/Xv3QxgL

If I browse to the folder and double click one of the solutions to open the NiceLabel Designer, I get the following error.
https://imgur.com/3Isim2i

This only happens with one machine, so I suspect it's more of a Windows problem than NiceLabel but am at a loss on where to look to resolve it.

Any help would be most appreciated.

Thank you

User avatar
dado
NiceLabel Development
NiceLabel Development
Posts: 691
Joined: Tue Sep 12, 2006 12:50 pm
Location: Kranj, Slovenia
Contact:

Re: iecore.dll error

Post by dado » Wed Apr 24, 2019 7:22 pm

Hi Ian

Can you double check if you have the iecore.dll file in the c:\program files\nicelabel\nicelabel 2019\bin.net\x86 and c:\program files\nicelabel\nicelabel 2019\bin.net\x64 folders.

Is there any AntiVirus application blocking access to iecore.dll? Are there any event log errors?

Regards, Damjan

IanG
Enthusiast
Posts: 7
Joined: Thu Mar 09, 2017 10:04 am

Re: iecore.dll error

Post by IanG » Thu Apr 25, 2019 2:56 pm

Hello,

Thank you for the quick reponse.

The user of the computer in question is on holiday for a week so will not be able to check but I can remember seeing iecore.dll in both the x86 and x64 directories when I was investigating the issue last week.

I did not check Event Log, but will do this when I can.

One thing I did notice yesterday was that if I created a new solution (on the troublesome machine) and save into the same folder, then the new solution would appear along side the existing ones but with a working thumbnail. I could then open it as normal.

It appears to be a problem only with the existing three solutions.

If have to I'll re-create the solutions, trying to avoid this though as it will affect other users.

User avatar
dado
NiceLabel Development
NiceLabel Development
Posts: 691
Joined: Tue Sep 12, 2006 12:50 pm
Location: Kranj, Slovenia
Contact:

Re: iecore.dll error

Post by dado » Thu Apr 25, 2019 9:53 pm

Hi

Something like a stack trace which is usually in the event log would be really helpful here.
But what is strange is that this happens only on one system. Maybe creating a new solution does not use some part of the code which would cause the crash and that is why it works then.

If this is system related I don't know what could we do here unless we somehow reproduce the problem here in the HQ. And even then I hope there is not something with .Net Framework or any other system related components.

Regards,
Damjan

IanG
Enthusiast
Posts: 7
Joined: Thu Mar 09, 2017 10:04 am

Re: iecore.dll error

Post by IanG » Fri Apr 26, 2019 2:20 pm

Hello Damjan,

I agree it would be difficult to reproduce, as I can't even do it here.

I won't have access to the computer for another week but the more I think about it, the more I suspect it's the system and I understand you can't do anything your end if it is.
The solutions use an Access database, while the new test one didn't. Perhaps it's the Access Runtime gone off. I will attempt to re-install this when I can.

The solutions are just a form, with around a dozen label templates with Access data source.
My backup plan is just to re-create them all again, not ideal because of the work involved but not the end of the world either.

User avatar
dado
NiceLabel Development
NiceLabel Development
Posts: 691
Joined: Tue Sep 12, 2006 12:50 pm
Location: Kranj, Slovenia
Contact:

Re: iecore.dll error

Post by dado » Sat Apr 27, 2019 12:32 am

Before re-doing all the labels once again could you just check if you have Access Runtime 2013 installed. I know there are problems with 2016 versions and that 2013 is the most reliable one.

Regards, Damjan

Post Reply