Page 1 of 1

Non-NiceLabel print driver issues

Posted: Wed Jul 10, 2019 3:53 pm
by HaydnWVN
Hi

Having a strange issue which is almost certainly linked to using non-NiceLabel drivers for an old printer NiceLabel do not have a driver available for. Nicelabel have already said they cannot support me using this printer with NiceLabel, so I'm asking the community here if they've experienced/troubleshooted similar with old equipment and have any pointers. I have seen this same symptom with supported printers using non-NiceLabel drivers.

The symptom - I'm using Automation with a variable to determine the quantity of labels to print. This printer/driver combo does not print that reported quantity, a seemingly random quantity higher than required. So 3 lines in Automation with a Quantity of 15,15,15 for example just printed 17,21,28 labels. :shock: :lol:

The printer in question is a colour thermal, a Toshiba TEC CB-416-T3-QP. It has been discontinued by Toshiba since 2013 so there are no X64 drivers. Or even any updated/newer drivers for it newer than Windows XP. NiceLabel would not print to it directly with it installed from a IP->LPT Print Server (using old Seagull driver, or Bartender driver). But sharing the print queue for it via an old Ubuntu server (our previous pre-NiceLabel configuration), The Windows Server running NiceLabel Automation is able to print to that mapped printer and has it outputting labels perfectly, just with this variable Quantity output! :-k

Toshiba did not replace this colour thermal in their range, other colour thermals from other manufacturers are far too expensive for us/our use. If I cannot resolve this I think we will probably move to printing on a colour laser on A4 sheets of labels, a far cheaper solution!

Re: Non-NiceLabel print driver issues

Posted: Thu Jul 11, 2019 2:12 pm
by Kyleodonnell
HaydenWVN,

When you do a preview in automation, does it show a random quantity as well or does the right quantity show?

Re: Non-NiceLabel print driver issues

Posted: Thu Jul 11, 2019 5:20 pm
by HaydnWVN
Hi Kyle

The correct number is shown in Preview. The correct quantity is shown in Automation as I'm passing a variable with the Label Print Quantity, NiceLabel is showing this in the log.

For this particular file I'm looking at:
Qty in trigger File:
1,1,2,5,5,5,5,10,10,5,5,5,10,5,10,5,5,5,5,8,5
Qty print shown in Automation:
1,1,2,5,5,5,5,10,10,5,5,5,10,5,10,5,5,5,5,8,5
Qty that actually printed:
1,1,2,3,3,3,3,4,4,3,3,3,2,3,4,3,3,3,3,4,3

The Qty printed does have some relationship to the Qty asked for in this example. A Qty over 20 seems to cause the rest to 'drift' further out. Smaller numbers like these do not seem to drift the same, just be consistently wrong. #-o

Re: Non-NiceLabel print driver issues

Posted: Thu Jul 11, 2019 8:42 pm
by Kyleodonnell
HaydenWVN,

You can try to use the "start printing after last page is spooled" setting
printersettings.PNG
printersettings.PNG (17.25 KiB) Viewed 326 times
so that it will spool the job, then print the labels to see if that fixes the random quantity issue

Re: Non-NiceLabel print driver issues

Posted: Fri Jul 12, 2019 4:17 pm
by HaydnWVN
Hi Kyle

Excellent advice - as so far so good with my tests - quantities are matching and are as expected...! :D

Huge thank you, gets us through this phase (Software switch-over) and allows us time to look at what our alternatives are in future.