TEC Backfeed and Tearoff

Issues related to using NiceDrivers thermal printer drivers

Moderators: Georges, milos, NiceLabel Support Team

Post Reply
howb
Newcomer
Posts: 1
Joined: Tue Aug 08, 2017 2:59 pm

TEC Backfeed and Tearoff

Post by howb » Tue Aug 08, 2017 3:36 pm

Using the Nice Label driver for TEC B-572 printer, version 5.1.06, with a setup that includes .25" of backfeed and .50" of Tearoff adjustment. A .net app sends a batch of labels, with a page per label.

On two machines (one a Windows 7 machine, the other a Windows 10 machine), the labels print properly, with the backfeed done at the beginning, and the tearoff adjustment after all the labels printed.

On two other machines (both Windows 10 machines), the labels do not print properly, but backfeed for each label.

Any idea of why the difference? If checked driver settings for differences and there are none. Bi-directional printing is enabled. They are set up with TCP/IP ports, and those ports are set up using the RAW setting.

If anyone can help me with the control codes for Backfeed and Tearoff, it would likely be a better way of doing this, yes?

Thanks

User avatar
Saso
NiceLabel
NiceLabel
Posts: 2880
Joined: Mon Sep 04, 2006 8:09 am
Contact:

Re: TEC Backfeed and Tearoff

Post by Saso » Thu Aug 10, 2017 12:31 pm

Do you use .NET app to communicate with NiceLabel SDK and print NiceLabel templates, or do you use NiceLabel printer driver without NiceLabel software?

Try to capture print file from one and the other computer and compare them.
Use "print to file" or get the print file (.SPL file extension) from Windows Spooler.

Do you use print server where the drivers are shared?
  • The printer driver defaults for the local user (where the driver is shared) are set in Printing preferences.
  • The printer driver defaults for the network users (who will use this shared driver) are set in Printer properties>Advanced tab>Printing Defaults... button.
Saso Fleiser
Senior Technical Product Specialist

Post Reply