Printer feeds empty label

Issues related to label design (working with databases, data processing, RFID encoding etc.) and printing (from NiceLabel Express, NiceLabel Pro, NiceForm and NicePrint)

Moderators: Georges, milos, NiceLabel Support Team

Post Reply
ManoloElLoco
Newcomer
Posts: 2
Joined: Sat Nov 23, 2019 1:34 pm

Printer feeds empty label

Post by ManoloElLoco » Sat Nov 23, 2019 2:01 pm

I hope there is an easy solution to this problem. Honestly, I'm new to NiceLabel Software, but with some experience in label printing:
We are using a brand new Epson TM-C3500 with a custom sized endless round label. The round label has a diameter of 85mm, and the gap between each label in 3.9mm on the roll. I tried several media settings meanwhile, but the printer always feeds one additional empty label after printing one label (this one printed label is printed correctly). I'm using NiceLabel Designer Version 19.1.1 in Express mode to send the print job.
My latest media settings are:
Media Width: 90.0mm
Media Height: 86.0mm
Media Form: Die-Cut Label (Gap)
Orientation: Portrait
Borderless Printing: Yes
Print Position Adjustment (found by trial and error):
Vertical: -2.9mm
Horizontal: 0.0mm
Any help is highly appreciated.
TIA
Manuel

highfrost
Enthusiast
Posts: 17
Joined: Tue Aug 19, 2014 10:51 am

Re: Printer feeds empty label

Post by highfrost » Thu Nov 28, 2019 11:37 am

Hello Manuel,

I have had this problem with several different causes as well.

First thing I always check is my label file, is it made for the printer you are sending it to and is your paper size correct.
I usually set this to manual and put the size of the label hard for this layout.
For instance if you made the label for your standard a4 printer the label printer will try to print this standard size and will give one or more extra labels.

Other thing what I have seen is the backfeed from the printer is incorrect. The printer starts printing a few mm away from the label edge and when it's sees the other edge of the label via the sensor it still has something to print. And so prints another empty label.
This is easily tested by making a label with height 80mm and see if this prevents the second label from being printed.

Hope this helps a bit, these are very annoying problems that are in my experience different with every printer type/settings.

ManoloElLoco
Newcomer
Posts: 2
Joined: Sat Nov 23, 2019 1:34 pm

Re: Printer feeds empty label

Post by ManoloElLoco » Thu Nov 28, 2019 4:42 pm

Hello and thanks, Highfrost :D
Meanwhile I found the solution and with this knowledge now I can confirm your idea with the label length setting. The technical reason is that the sensor for label detection of die-cut gap labels is not in the exact middle of the paper path. In the TM-C3500 Epson printer it is placed about 8.5mm beside the median. This doesn't matter for square label formats, but for round labels on the carrier it makes a significant difference. Due to the curve of the label's edge the sensor "sees" the label a bit later and printing starts a bit "too late". Than the printer prints and forwards the full label as given in the settings, and the sensor detects the next label already when finished. This causes the printer to feed paper until the sensor detects the next gap, which gives as a result the blank label extra.
I shortened my lenght setting to 82.00 mm for my 85.00 mm round label, and with this setting everything is fine now.
Thanks again
Manuel

highfrost
Enthusiast
Posts: 17
Joined: Tue Aug 19, 2014 10:51 am

Re: Printer feeds empty label

Post by highfrost » Fri Nov 29, 2019 4:11 pm

ahaaa, that makes sense :)

Might be a good idea to consider asking your label supplier to put square black backmarkers on the backpaper.
This way the printer will see it as if it is a square label.

Post Reply